Solved Neither Spacebar, <Enter> nor "Play" Button on Control Causes Playback

  • Posts: 10
  • Karma: 2
  • Thank you received: 3

Neither Spacebar, <Enter> nor "Play" Button on Control Causes Playback was created by beau

I've just installed Audio Studio on a new computer and everything looks OK, but there's no way to initiate playback.
On my old computer, spacebar, or Enter or clicking the Play arrow would all start playback.
What's going on here?

Edit:
In Options > Preferences > Playback I've checked "Spacebar and F12 Play/Pause instead of Play/Stop" and now when I hit spacebar or the Play arrow, I get the message "waveform output device 'x' can't play this format! Reason: A device ID has been used that is out of range for your system"

In System Options > Playback > Global Play Device shows no entries.
19 Feb 2018 03:43 #1

Please Log in or Create an account to join the conversation.

  • Posts: 3611
  • Karma: 59
  • Thank you received: 1306

Replied by DoctorZen on topic Neither Spacebar, <Enter> nor "Play" Button on Control Causes Playback

Before I can say anything, I need to know which exact program you are talking about, because there is no program called just "Audio Studio" ?

Full name of program please and version number.
Also, open whatever program you are using and go to Help/About - which build version do you have installed ?
Remember to turn everything off at least once a week, including your brain, then sit somewhere quiet and just chill out.
Unplugging is the best way to find solutions to your problems.
Peace :)
19 Feb 2018 12:56 #2

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Karma: 2
  • Thank you received: 3

Replied by beau on topic Neither Spacebar, <Enter> nor "Play" Button on Control Causes Playback

Sorry DOCTORZEN for the lack of full info.

I'm running Sound Forge Audio Studio 12 12.5.0.337(DP3)

On the old computer (on which Audio Studio runs fine) in Options > Preferences > Playback the Global Play Device listed is Speakers (Realtek High Definition) .
I have the same Realtek on the new computer, and on Start > Sound > Playback the same Realtek is listed as the default device. Payback of audio files works perfectly well using WinAmp.

Something tells me if I can get Speakers (Realtek High Definition) in the Options > Preferences > System Options > Playback > Global Play Device window then things will playback OK. As I mentioned before, there's nothing at all in the Global Play Device field.

Please let me know if you need more information.
The following user(s) said Thank You: DoctorZen
19 Feb 2018 13:51 #3

Please Log in or Create an account to join the conversation.

  • Posts: 3611
  • Karma: 59
  • Thank you received: 1306

Replied by DoctorZen on topic Neither Spacebar, <Enter> nor "Play" Button on Control Causes Playback

Thanks for the detailed information.

I have the exact same program and version installed on my own computer.
Using default settings and changing nothing in the Playback settings, Spacebar plays any file on the timeline.
J, K & L also work for reverse, stop, play/forward/speed increase.

I think you have already provided the actual reason for your problem.
You said:

I get the message "waveform output device 'x' can't play this format! Reason: A device ID has been used that is out of range for your system"


I think what this means is that your Sound Device is not correctly configured to work with Sound Forge.
Magix has down a massive overhaul/upgrade on Sound Forge Audio Studio, which means there are more complex options available now.

I have a suggestion for you, which may fix this problem.
The first thing I recommend you do is reset Sound Forge to the default settings.
Go to Help / Restore default application behaviour
Doing just this simple thing, may fix your problem.

If you want to do a test after the reset, I recommend you don't use the same .wav file, but select an everyday .mp3 audio file.
Just in case the .wav file was part of the problem.

The second thing you need to do, is check your Windows Sound Card settings.
The options available to you here, will be different on every computer, because it depends what type of Sound Card/s you have installed.

Right-click the Speaker icon in lower right corner of Taskbar.
Select Playback Devices and make sure the correct Speakers option has been set as the Default device.
If you don't see a green tick next to the Speakers that look like the correct option for your computer, right-click and select Set as Default Device.



Next go to the Recording tab.
If you have a Microphone connected, it should be set as the Default device.
If you don't have a Mic connect, What U Hear should be the default



Now lets go back to Sound Forge Audio Studio, if you still have a problem.
Go to Options / Preferences / System Options / Audio Setup
The Driver system is what links the Sound Forge to your computers Audio system
Click the drop down box at the top.
If you have ASIO drivers installed, they are the best for audio work.
If you don't, select your Realtek drivers and do a test.
If there are multiple options, try them all until you find the one that works.

Also check Global Playback Device at the very bottom.
It should automatically set to the correct option, each time you select a different driver at the top, but can be manually changed if there is more than one option.



Final thing.
Make sure your Realtek Drivers are up to date!
Go Windows Control Panel and select the Device Manager
Go to Sound, Video and Game Controllers
Right-click on Realtek Drivers and select Update Driver
Windows should be able to find any new drivers for you.



Regards
Derek
Remember to turn everything off at least once a week, including your brain, then sit somewhere quiet and just chill out.
Unplugging is the best way to find solutions to your problems.
Peace :)
19 Feb 2018 15:30 #4
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 3611
  • Karma: 59
  • Thank you received: 1306

Replied by DoctorZen on topic Neither Spacebar, <Enter> nor "Play" Button on Control Causes Playback

Additional information
The Sound Forge Help file, says this about the selection of Drivers.

Audio Setup
Driver system: You may select WASAPI, ASIO, WDM or MME for communication between Sound Forge Audio Studio 12 and your sound card. Choose the sound card driver that you would like to work with here. The drivers for all devices installed on the system will be listed here. We recommend using WASAPI or ASIO drivers.

ASIO settings: Clicking the "Settings" button opens the settings dialog for the sound card driver. In the display field beside "ASIO buffer", you'll see the buffer size and bit rate set for the driver.

16/24/32-bit device/driver communication: If your sound card is able to play 24-bit audio, your project will be played at this higher resolution (internal 32-bit float calculation). This is applicable only to MME drivers.

Standard device: If the driver has several outputs, select the device that will be used for playback.
Remember to turn everything off at least once a week, including your brain, then sit somewhere quiet and just chill out.
Unplugging is the best way to find solutions to your problems.
Peace :)
19 Feb 2018 16:51 #5

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Karma: 2
  • Thank you received: 3

Replied by beau on topic Neither Spacebar, <Enter> nor "Play" Button on Control Causes Playback

Hi Derek ~
Thank you for your extraordinarily (!) detailed comments
Followed your instructions, everything working fine now.

First restored default application behavior
Under Sound > Playback, the Realtek was already the default device.
Then I selected a mic under Recording
Then when I went back to Options > Prefs > System Options > Audio Setup . . and Reatek was listed as the Global Play Device.
Et Voilà!

Now under Driver Systems I have four choices:
WASAPI Speakers (Realtek)
Magix Low Latency 2016
WDM
MME
They all work, but I did only rough tests so I don't know if one is better than the others.
I've settled on Magix Low Latency 2016

Also updated Realtek driver, already had the current.

Very kind of you to have taken so much time on a Sunday afternoon to give such a detailed explanation.
Many thanks!

Cheers!

~ beau
The following user(s) said Thank You: DoctorZen
20 Feb 2018 01:12 #6

Please Log in or Create an account to join the conversation.

  • Posts: 3611
  • Karma: 59
  • Thank you received: 1306

Replied by DoctorZen on topic Neither Spacebar, <Enter> nor "Play" Button on Control Causes Playback

Before I answered your message, I did some deep Google searches and found many people experiencing the same problem, going back for years.
The problem was not specific to just Sound Forge, but universally applies to any Audio Editing software program.
Hopefully my detailed checklist will help many other people in the future now.

I'm glad you got it working :)
Remember to turn everything off at least once a week, including your brain, then sit somewhere quiet and just chill out.
Unplugging is the best way to find solutions to your problems.
Peace :)
The following user(s) said Thank You: beau
20 Feb 2018 09:54 #7

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Karma: 2
  • Thank you received: 3

Replied by beau on topic Neither Spacebar, <Enter> nor "Play" Button on Control Causes Playback

Hooray!
23 Feb 2018 08:10 #8

Please Log in or Create an account to join the conversation.

Moderators: DoctorZen
Time to create page: 0.137 seconds

Make a Donation

Movie Studio Zen is a fully independent site and all our content is free. You can help support this site by making a PayPal donation.

MSZ Social Media

youtube  facebook  twitter

MSZ Security

MovieStudioZen.com

Copyright © 2019 MovieStudioZen.com.
All rights reserved.

Back to top