Question Vegas Pro 17 - Static/Distorted sound

  • Posts: 1
  • Karma: 1
  • Thank you received: 0

Vegas Pro 17 - Static/Distorted sound was created by gracefullmess

I have been looking everywhere for an answer to this problem and so far nothing has worked.
I have Vegas Pro 17. I am importing 1080p mp4's. When I drop them into the timeline the audio let's of this high pitched screeching noise.
I found videos on youtube that said to go to preferences > internal > type so4 > then disable one of the options (Each tutorial suggested disabling a different option, so I tried all four of them) One of these options worked...It did fix the audio, however, the video disappeared.

I upgraded to 17 because it has a mkv option, when I import 1080p mkv's the audio worked fine. I have tried disabling the mkv option, in case it was messing with the program, because I know it's experimental and they havn't worked out the bugs yet....but it made no difference when disabled it.

Does anyone know something I can do that will fix this problem???
28 Nov 2019 11:43 #1

Please Log in or Create an account to join the conversation.

  • Posts: 4024
  • Karma: 59
  • Thank you received: 1402

Replied by DoctorZen on topic Vegas Pro 17 - Static/Distorted sound

Hi gracefullmess

I need to know what type of video you are working with, which is causing this problem.
It sounds like a codec problem to me.
.mkv and .mp4 are not video codecs, they are file containers.

There were some problems with the new Magix AVC encoder "so4" when it was first added to Vegas Pro, starting with Vegas Pro 15, however as far as I am aware most/all of those problems have now been fixed in Vegas Pro 17. Be very careful with some of the advice on YouTube. Some Youtubers tell people to do absolutely ridiculous things.

Where did your video come from ?
Which program or device made the original video ?
I'm guessing this came from a screen capture program like OBS ???

Which Graphics Card do you use ?
Which Graphics Driver do you have installed ?
Which Graphics Card do you have turned ON in the Vegas preferences ?
Go to Options/Preferences/Video - GPU Acceleration

Use a free app called Media Info to make a report about your video.

I have instructions on how to set up Media Info in this forum post here:
Copy and Paste the Text readout from Media Info into the forum.

I am also a bit worried about all the internal settings you have been mucking around with.
I recommend you restore Vegas Pro to the default settings, before doing anything else, otherwise I won't be able to help you.
Reset instructions here:

:idea: Remember to turn everything off at least once a week, including your brain, then sit somewhere quiet and just chill out.
Unplugging is the best way to find solutions to your problems. If you would like to share some love, post a customer testimonial or make a donation.
Peace :)
28 Nov 2019 19:49 #2

Please Log in or Create an account to join the conversation.

Moderators: DoctorZen
Time to create page: 0.092 seconds

Make a Donation

Movie Studio Zen is a fully independent site and all our content is free. You can help support this site by making a PayPal donation.

MSZ Social Media

youtube  facebook  twitter

MSZ Security

Copyright © 2020
All rights reserved.

Back to top