Solved My video is being kinda pixelated after render?

  • Posts: 3
  • Karma: 1
  • Thank you received: 0

My video is being kinda pixelated after render? was created by TeamL

Hi, my name is Laust, I'm a danish Youtuber who have some trouble with the editing program "Movie Studio Platinum 13".
I record Minecraft videos, with a program called "Bandicam" and it works fine. But when I have edited and rendered the video, the video just looks kinda pixelated when I'm doing quick movements. And I have tried to turn off the "Resample" and that do not help.. I have some example down below on how my video is looking and what I want it to look like. BTW, I have a good pc with a GTX 1080, i7 7700k, and 16 gb ram. So I don't think that it's my computer. But here is some examples:

My video (See the first 30 seconds):


What I want (Go to around 7:30 and see the following 30 seconds):


I also have Adobe Premiere Pro 17, and same result.

I you guys can help :)
Thanks,
Laust Larsen
08 Nov 2017 21:05 #1

Please Log in or Create an account to join the conversation.

  • Posts: 3776
  • Karma: 59
  • Thank you received: 1352

Replied by DoctorZen on topic My video is being kinda pixelated after render?

Hi TeamL

Explanation:

The problem is being caused by the motion being insanely fast on the screen and the video codec does not have enough Bit Rate to encode each frame.

All videos that are rendered (outputted) by any Video Editing program, use compression to keep the file size as small as possible.
If you did not render your videos with a "finishing codec" like Mainconcept AVC/AAC, the video would be uncompressed and the file size would be absolutely MASSIVE and impossible to upload. You can try this experiment yourself and render your project to "Video for Windows .avi" which is an uncompressed format. The file size will be HUGE! However, you should see a perfect image.

Rendering to an uncompressed format is not practical and no one would ever do this for a final video output.

When you render to something like Mainconcept AVC/AAC, the video codec algorithm does not encode every single frame of your video, like a series of perfect still pictures. Instead, it looks for areas of each frame which are not changing and tries to use the same information to encode multiple frames at the same time - doing this helps to keep the file size much smaller (this is part of video compression).

If you take the example of someone being interviewed and they are sitting in a chair, the only part of each video frame that changes will be in their face and maybe arms and hands moving. All of the background does not change, so that data can be used for multiple frames at the same time. This means that the final video looks very sharp and the file size is very small.

When you add high speed motion into each video frame, there is not much data that can be copied from one frame to the next.
When rendering high speed video, you need to use much higher Bit Rates, so that there is more data allowance to encode each frame.
However, even with a higher Bit Rate allowance, it becomes almost impossible for the Video Codec to compress the video file, so the video ends up looking pixelated in many different parts of each frame.

All videos you see on YouTube are highly compressed by YouTube.
YouTube uses a special video codec that does "super-compression" on each video, to reduce the file size.
This compression does degrade the origin video image.


Solutions:

1. Render with higher Bit Rate settings - however don't set at extreme levels.

2. Turn on Two Pass rendering

3. Vegas Pro users often use a process called Frame Serving to Handbrake. Unfortunately you cannot do this with Movie Studio. Frame Serving to Handbrake means that you get Vegas to render with Handbrake instead. Handbrake uses a superior video encoder engine that is better than the Mainconcept Encoder that comes with Vegas. The Handbrake encoder does a better job of handling high speed motion.

4. If you have a LARGE amount of space on your Hard Drive, you could render your video to Video for Windows .avi first - this will produce a massive file.
Then render the video with Handbrake to make it smaller.
After you have completed the 2nd render, you could delete the MASSIVE .avi file version from your hard drive.
You should find the new video created with Handbrake looks better than the Vegas Pro Mainconcept AVC/AAC version.

handbrake.fr/

Regards
Derek
Remember to turn everything off at least once a week, including your brain, then sit somewhere quiet and just chill out.
Unplugging is the best way to find solutions to your problems.
Peace :)
The following user(s) said Thank You: ericlnz, TeamL
09 Nov 2017 15:06 #2

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Karma: 1
  • Thank you received: 0

Replied by TeamL on topic My video is being kinda pixelated after render?

Hi DoctorZen, thanks for the response!
I've tried it and I don't think it worked. And what I mean by that is the quality is now more bad than before. I think it might be the settings when I render the avi from Movie studio and the settings in Handbrake. Could maybe help me with some of the settings, if the video should be in 1920x1080 60fps?

Thanks you so much again :)
Best regards,
Laust
10 Nov 2017 04:29 #3

Please Log in or Create an account to join the conversation.

  • Posts: 3776
  • Karma: 59
  • Thank you received: 1352

Replied by DoctorZen on topic My video is being kinda pixelated after render?

Hi again TeamL

I have not forgotten you :wink:

Here are all the important things to check when editing gaming screen captures with Vegas Movie Studio.

1. If you want to edit Gameplay videos, you need to record your videos using a Constant Frame Rate.
The highest Frame Rate you can record to is 60 fps (59.94).
If your screen capture device or screen recorder used a Variable Frame Rate, you will need to convert the video to a Constant Frame Rate first, because all Video Editing programs can only work with Constant Frame Rate video.
Bandicam should be recording to Constant Frame Rate by default, so you shouldn't have to worry about this, however I am mentioning this in case other YouTuber's read this forum thread in the future and have a similar problem.

2. Make sure your Project Properties in Vegas Movie Studio, match the Properties of your Gameplay video exactly !
If your video capture used a Frame Rate of 60.00 fps, make sure the Frame Rate in Movie Studio is also set to 60.00 fps.
If your video capture used a Frame Rate of 59.94 fps, make sure the Frame Rate in Movie Studio is also set to 59.94 fps.

Your Project Properties should look something like this:


3. Make sure that Re-sampling Mode is turned OFF for all your videos on the timeline - this will reduce Motion Blur and make video look sharper.
Right-click videos (you can select as a group) and go to Switches / Disable Resample


4. To render an un-compressed video, go to Make Movie / Save to Hard Drive / Advanced
I really don't like using this method, because the file size will be MASSIVE - you will need a lot of room on your Hard Drive.
If you don't have much room on your Hard Drive, you cannot use this method! - skip to No.6 instead.
Select Video for Windows .avi and HD 720-60p YUV to start with - you will edit this in the next window.


5. Press Customize
Set Frame Size = 1920x1080
Set Frame Rate = 59.94 or 60.00 (match your video's frame rate)
Set Video format to Sony YUV Codec or Uncompressed.
Sony YUV will create a slightly smaller file size.


6. If the file sizes are TOO LARGE from rendering with Video for Windows .avi uncompressed, you could try rendering with Sony XAVC S instead.
Sony XAVC S uses a Bit Rate of about 50 to 70 Mbps and works well with normal video, but I'm not sure how it will go with Gameplay - however it is worth doing an experiment. Sony XAVC S will produce much smaller file sizes. You do not need to customise any settings with this format.


7. After you have rendered your "Intermediate" video format with Vegas Movie Studio, it is time to use Handbrake to make the file size smaller and better for uploading to YouTube.
handbrake.fr/

Add your video to Handbrake
Ignore the Picture and Filter tabs.

Go to the Video tab and use these settings:
Video codec = H.264
Frame Rate = 59.94 or 60.00 (use what your video uses)
Set to Constant Frame Rate
Set Encoder Profile = High
Set Encoder Level = Auto
Quality Slider = 20 is normally a good setting - the lower this number is, the higher quality the video is, but also larger file sizes with small numbers.
Enable 2-Pass Encoding
Enable Turbo first pass


Go to Audio tab - experiment with what you like.
AC3 is an OK option


Go to Subtitles tab and press X to remove


Go to Chapters tab and deselect


When finished with settings, you can create a Preset for next time - press +Add bottom right corner.

8. Press START ENCODE to begin video conversion with Handbrake

I recommend you do some 1 minute video tests and try different quality settings in Handbrake.
So render 1 minute samples with Movie Studio first and test them with Handbrake.

I hope this helps you out :)
I am not a gamer, because I don't have the time, but would be interested in your report back if this helps/works.
Remember to turn everything off at least once a week, including your brain, then sit somewhere quiet and just chill out.
Unplugging is the best way to find solutions to your problems.
Peace :)
13 Nov 2017 18:37 #4

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Karma: 1
  • Thank you received: 0

Replied by TeamL on topic My video is being kinda pixelated after render?

Hey DoctorZen,
I will try and see if it works :)
Thanks you :)

Regards,
Laust Larsen
17 Nov 2017 08:50 #5

Please Log in or Create an account to join the conversation.

Moderators: DoctorZen
Time to create page: 0.377 seconds

Make a Donation

Movie Studio Zen is a fully independent site and all our content is free. You can help support this site by making a PayPal donation.

MSZ Social Media

youtube  facebook  twitter

MSZ Security

MovieStudioZen.com

Copyright © 2020 MovieStudioZen.com.
All rights reserved.

Back to top