Solved Lost free effects plugin after reinstall of MSP15

  • Posts: 8
  • Karma: 1
  • Thank you received: 0

Lost free effects plugin after reinstall of MSP15 was created by Mr. Weather

A few years ago I installed MSP 15 on Windows 10. Recently I had to reinstall the OS and MSP 15, but now I'm missing the "Witness Protection" effect which made it easy to blur any part of the screen. I think this plugin was included free with my MSP 15 purchase the time. Does anyone know how I can get that back?
11 Oct 2020 09:20 #1

Please Log in or Create an account to join the conversation.

  • Posts: 4121
  • Karma: 59
  • Thank you received: 1425

Replied by DoctorZen on topic Lost free effects plugin after reinstall of MSP15

There are 2 things you need to do.

Going by my records, Movie Studio 15 Suite version came with NewBlueFX Suite Complete and HitFilm Boost Pack.
I no longer have either of those packs installed, so can't verify which Video FX came with these packs, however I believe that Witness Protection came with the HitFilm Boost Pack.
To re-install everything that came with Movie Studio 15 Suite, run the installer program.
To get the installer, go to this page and enter your serial number. Then press the download link for Installation program and run it.
www.magix.com/us/support/my-service-center/product-downloads/

You will also need to find your Serial Number for HitFilm Boost Pack.
This came with the email Magix sent you, when you bought Movie Studio 15 Suite.

Regards
Derek
:idea: Remember to turn everything off at least once a week, including your brain, then sit somewhere quiet and just chill out.
Unplugging is the best way to find solutions to your problems. If you would like to share some love, post a customer testimonial or make a donation.
Peace :)
12 Oct 2020 07:20 #2

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Karma: 1
  • Thank you received: 0

Replied by Mr. Weather on topic Lost free effects plugin after reinstall of MSP15

Thank you for the assistance! I will have to dig up the serial numbers for the other products but this gives me a path forward!
12 Oct 2020 07:51 #3

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Karma: 1
  • Thank you received: 0

Replied by Mr. Weather on topic Lost free effects plugin after reinstall of MSP15

Brief update:

I'm making slow progress on this. I opened a support ticket with Magix and t hey were able to provide the serial numbers for the New Blue and HitFilm plugins. After asking for the actual software, Magix support provided 2 links and I was able to download the installers. Upon installing those, I have to log into the NewBlue website and that is the next hurdle. I am caught in a loop of password resets which never seem to work, and I finally just opened a ticket for NewBlue support to get that ironed out. Ironically, that request for support triggered yet another request for me to log in their system which is the whole problem in the first place.

So at least at this point I have a) the software, and b) the serial numbers. So I'm 2/3 of the way there.
15 Oct 2020 02:38 #4

Please Log in or Create an account to join the conversation.

Moderators: DoctorZen
Time to create page: 0.109 seconds

Make a Donation

Movie Studio Zen is a fully independent site and all our content is free. You can help support this site by making a PayPal donation.

MSZ Social Media

youtube  facebook  twitter

MSZ Security

MovieStudioZen.com

Copyright © 2020 MovieStudioZen.com.
All rights reserved.

Back to top